We are running a sale on Popup Card Studio. Save 28% right now during this very limited time sale. Click here to order now!

We are also running a sale if you purchase both Make The Cut! and Popup Card Studio. Save 38% right now during this very limited time sale. Click here to order!

Zing driver [Resolved]

Iceman567Iceman567 Member Posts: 4
edited September 2015 in Resolved Issues
Purchased a slightly used Zing. Purchased the MTC software from Sandy. It's all registered. Installed the Zing plug-in. Plugged in the USB from Zing to laptop (Windows 7). Error message, failed to install driver. Went to KNK website and tried to download drivers there, CDM v2.12.00 WHQL, extracted files, another error message, 'the requested operation requires elevation'. HUH?

The laptop recognizes that there is something plugged into one of the USB ports. Just won't install the driver.

Have a project in MTC, clicked to print/cut. Zing dashboard comes up. 'not connected'. Clicked 'refresh ports'. Nothing.

Wondering if it's an issue with my laptop, sent back a Cameo because of the same issues. Their support was useless, BTW.

I am not computer illiterate, so I have tried most of everything except...?

TIA, Ted
Post edited by SBryanW on


This discussion has been closed.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!