We are running a sale on Popup Card Studio. Save 28% right now during this very limited time sale. Click here to order now!

We are also running a sale if you purchase both Make The Cut! and Popup Card Studio. Save 38% right now during this very limited time sale. Click here to order!

Original Cameo is not powering up any more.

johnjbjohnjb Member Posts: 1
I recently started having trouble getting my trusty Cameo 1 to power up.  I already did the SD upgrading deal to get it to work better with Windows 10, about 2 months ago,  and it's worked like a champ until yesterday.

I went through the troubleshooting process of what the Silhouette website says and nothing worked. After leaving it all unplugged for 10 minutes  I tried again and it worked . The adaptor does not get warm, so maybe that's a sign of something?

Went to bed and tried turning it on again today and same thing. This time nothing I do works.

I took the power adaptor to a battery store and they didn't have a replacement 24V one but they tested it and saw it was putting out a steady 24.1 Volts.

Took it home and plugged it in again with expectations of a miracle and still it won't turn on.

All it does and make a brief sound at the cutter head, like the start of a normal powering up type sound, and the display blinks and then nothing.

Silhouette store shows out of stock on a new adaptor and chord  so I ordered a 24v from Amazon and hope this works. It should arrive on Tuesday.

If this doesn't work I'm dead in the water.

Does anyone have any suggestions on a remedy other than what I've tried?

I took it apart to see if anything was loose or if there was a fuse but didn't see anything that could be wrong and I couldn't find a fuse.

If I bought one of the newest ones will all my hundreds and hundreds of design files in the library work with it? I hate to lose everything I have done over the years.

Any help will be appreciated.



  • Liz_ALiz_A Member Posts: 10,992
    @johnjb - we are not hardware support website. We are the Make The Cut! software support forum. While your cutter is supported we can't really help you with hardware issues. That is a Silhouette America direct issue. I am going to suggest that the problem is INSIDE the cutter where the power cord connects. Constant pulling the plug out or pushing the plug in over the years may cause a slight disconnection on the inside. That has been an issue with other cutter brands, I know for sure that the Silhouettes being a lower priced brand they would likely have similar issues. Start with that, open it up and take look. An electronics person may be able to help way faster than Silhouette. Good luck.
    Still using MTC but slowly migrating to SCAL. KNK cutters including the Force and Maxx Air continue to be my favourites. Fluent in other cutter languages.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!