We are running a sale on Popup Card Studio. Save 28% right now during this very limited time sale. Click here to order now!

We are also running a sale if you purchase both Make The Cut! and Popup Card Studio. Save 38% right now during this very limited time sale. Click here to order!

MTC 4.6.2 and Copam CP-2500, ALMOST works, but doesn't finish.

whackamolewhackamole Member Posts: 3
edited March 2016 in Wishlist!
Hello, I've been lurking on these forums for a while and thought I'd post some potentially interesting information if anyone has a COPAM CP-2500 USCUTTER vinyl cutter. Though I am quite disappointed that MTC doesn't have a native Copam driver after all this time, I AM able to get MTC 4.6.2 to partially work and draw my objects on paper (simulated cutting) as I'm using a pen adapter and roll of paper instead of cutter knife and vinyl using the Klic-n-Cut series plugin. It doesn't matter which model you choose from the model dropdown (KNK Maxx, KNK Groove-E, KNK Element/XL/Grand, KNK Maxx Air) either as all will draw the object you're wanting cut. BUT, I can't get the Copam to END the cutting procedure (the LCD screen on the Copam cutter says "Cutting..." and freezes and stays powered up and never finishes the procedure as well as doesn't power down as it would normally if all was working perfectly).

I have also tried the USCUTTER plugin for MTC but it simply moves the cutter in a strange way and makes a lot of noise but nothing draws at all.

The reason I'm posting this in your forum is that I had this same experience using a competitor product called SignGo and I worked with the author of that software to find a suitable fix to the problem for my cutter. Since these cutters all speak HPGL (Google Hewlett Packard Graphics Language for a primer on what all these commands mean), we had to use a modified END command to have success finishing the cutting procedure. The commands that we used that work for the Copam CP-2500 were as follows (NOTICE THE END FIELD - all punctuation is important, including the double semi-colon)

Initialize: IN;
Start plot: PA;
Start cut: PA;
Reset: IN;
Move: PU#,#;
Line: PD#,#;
Bezier curve: (BLANK FIELD)
End: PU;!PG;;
Set origin: PU;PA#,#;PG0;
Set depth: (BLANK FIELD)
Set speed: VS#;
Select pen: SP#;
Get plotting area: OH;PU;
Get Head Position: OA;

Anyhow, once we made that change, their software works properly and actually finished the drawing procedure and powers down afterwards (I had the exact same experience otherwise as I'm having with MTC 4.6.2 now). So I believe the above information may help Andy or whoever is authoring the software drivers these days to make a proper driver for the Copam CP-2500. I am willing to beta test this and offer feedback directly if indeed a driver is created.

Thank you.
Post edited by SBryanW on


This discussion has been closed.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!