We are running a sale on Popup Card Studio. Save 28% right now during this very limited time sale. Click here to order now!

We are also running a sale if you purchase both Make The Cut! and Popup Card Studio. Save 38% right now during this very limited time sale. Click here to order!

I Need Help (Resolved)

VanGrandmaVanGrandma Member Posts: 35
edited February 2010 in General
I bought a new computer. It has windows 7. I have tried and tried to down load the drivers but every time I try to cut it says there is a problem the drivers are not loaded. I have done everything anyone has suggested and nothing works. Please help.

Comments

  • iggyloveriggylover Moderator Posts: 11,513
    VanGrandma,
    Here is a link to a short thread with step-by-step directions for you.
    Thread titled: "Cricut Error: Unable to load drivers"
    http://make-the-cut.com/forum/comments.php?DiscussionID=856&page=1#Item_3

    Hope this helps. (If it does, please edit your post title to have the word "[RESOLVED]" Thanks.)
    Jeanette
    "All that is necessary for evil to triumph is for good men to do nothing" Edmund Burke Jeanette in Orange County, CA Love my Italian Greyhound --> I.G.--> iggy Own a Create: Krikee, getting used to a Black Cat Cougar: Bagheera
  • VanGrandmaVanGrandma Member Posts: 35
    I followed it step by step and it still will not load the drivers
  • tazkmastertazkmaster Member Posts: 67
    I know it will work with Windows 7, because I read a post that someone was using it on a netbook running Windows 7 yesterday. Sure hope they check in and can help you.
  • AndyAndy Administrator Posts: 4,579
    I use windows 7... and 64 bit. MTC is developed on Win7.

    In Win7, you shouldn't have to download/install drivers. The drivers should be already installed on your computer.

    What you need to do is Shut down MTC and unplug your cricut from your computer
    Plug your cricut back into your computer, and <b>power the cricut machine on</b>
    You should see some activity on your desktop that drivers are being installed.
    If you don't see that, unplug the cricut and reboot. Then start this process over.

    Once you have done it where something pops up on your desktop saying "installing new hardware", wait for it to finish then start MTC up and try cutting
    I don't often test my code... But when I do, I do it in production.
  • VanGrandmaVanGrandma Member Posts: 35
    I went through this process 5 times and nothing happened. I went to where you remove hardware and it was there. I tried to get it to load the drivers but it said it could not find them.
  • ConiCutsConiCuts Member Posts: 1,673
    edited February 2010
    Jeanette,
    How does one edit their post to resolved? Anytime I edit a post there is no option to change the title line?

    Edited to add: Never mind, I figured it out! LOL
  • VanGrandmaVanGrandma Member Posts: 35
    I have not figured out how to edit my post! But it is resolved. Finally I can play!
  • AndyAndy Administrator Posts: 4,579
    awesome! I updated your post!
    I don't often test my code... But when I do, I do it in production.
This discussion has been closed.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!