We are running a sale on Popup Card Studio. Save 28% right now during this very limited time sale. Click here to order now!

We are also running a sale if you purchase both Make The Cut! and Popup Card Studio. Save 38% right now during this very limited time sale. Click here to order!

Windows 10

boop72boop72 Member Posts: 1
Do i  need to update if i am running windows 10, i have used my bosskut for a few years
Help
Thanks

Comments

  • Little_BerryLittle_Berry Member Posts: 5,725
    If it ain't broke don't fix it. Windows10 I think is a force uodate
  • Liz_ALiz_A Member Posts: 9,092
    @boop72 - update what? MTC has not been updated for a long time. Using Windows 10 you don't get any choice for automatic updates, Windows applies those when it wants, just make sure you explore what settings are there so that you do get asked for a restart once the update has been applied. Otherwise, Windows will just restart the computer and any not saved work is gone.
  • CroppyCatCroppyCat Member Posts: 94
    when I open MTC in windows 10 I can''t get to all the options... some are very hard to read, all looks squished and I can;t 'open' to make it beiiger... will there be a fix?
  • Di-liteDi-lite Member Posts: 2,895
    You need to change your display and increase your icon size or get Win10 to allow XP view of MTC - very tricky to get it just right - I wen round in circles for several days before I got it right.
    Have fun, Di, ID 14610
    UK, Cameo, Serif Draw, Win10.
    Link to My Craft Bazaar | Link to Skool | Force Bazaar - Archimedes
    Feel free to use anything in these links.
  • scrappinmelscrappinmel Member Posts: 24
    How do you change the display?  I've tried all different icon sizes and still can't get it to work.
    Cricut Expression 2008 & Proud owner of a KNK Zing 2011
  • tuicarlostuicarlos Member Posts: 70
    edited February 5
    @CroppyCat - Have you tried to reset the settings of your MTC software?

    1.       Open your MTC software

    2.       Click in “Help”

    3.       Click in “Advanced”

    4.       Click in “Reset Interface to Factory Settings”

    5.       Click in “Yes”

    If the above suggestion doesn't fix the problem, I suggest you to verify the display settings in your computer.

    Go to Start/Settings/System/Display. If your laptop has a small display and MTC has no option to change the size of text and icons, this is your place. 

    But, to make sure that everything is okay on the bottom click in "Advanced display settings" and make sure that you have the correct resolution (recommended).

    Also, on the same window under "Related settings", click in "Advanced sizing of text and other items". Make sure that all the options show “9” as size (default).

    I suggest you to keep the default size first and restart your computer. If it doesn’t fix the problem, you can change to any size you want but keep in mind… you still have a problem!

    If nothing above fix the problem, don’t panic… don’t jump… let we know so we can keep trying to help you. We appreciate if you give us more information about the problem. If it happens only with MTC software or not for example. Also, if you post some screenshots of your display here it could help us a lot.

  • CroppyCatCroppyCat Member Posts: 94
    Oh my goodness that worked!!! thank you so much was going crazy!!!
Sign In or Register to comment.